Monday, April 13, 2009

My PPA Repository for Filthy Pants (HandBrake Repository)

After much more time and effort than I care to admit, I finally got Canonical's build servers to successfully build deb binaries for HandBrake in my PPA repository.

From here on out, I will no longer distribute packages through Rapidshare, which some people didn't like, and will exclusively use the PPA repository. I will regularly build development packages of HandBrake with both the GTK and QT4 GUIs (the CLI version will also be included with the GTK package).

To access my PPA repository through apt (so updates happen properly and so forth), hop on a terminal and type:
sudo gedit /etc/apt/sources.list
and add these lines at the bottom:
#Filthy Pants PPA
deb jaunty main
deb-src jaunty main
Save and close, then type:
sudo apt-key adv --recv-keys --keyserver 0x065fda2d23cfea71e753d04703e1fe8b2796dec2
After that, type:
sudo aptitude update
and you're all set.


Anonymous said...

Thanks for your effort. For me, unfortunately:

"sudo apt-get install handbrake
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
handbrake: Depends: libdbus-glib-1-2 (>= 0.78) but 0.74-2 is to be installed
Depends: libenchant1c2a (>= 1.4.2) but 1.3.0-5 is to be installed
Depends: libgtk2.0-0 (>= 2.16.0) but 2.12.9-3ubuntu5 is to be installed
Depends: libgtkhtml3.14-19 (>= 3.26.0) but 3.18.3-0ubuntu2 is to be installed
Depends: libpopt0 (>= 1.14) but 1.10-3build1 is to be installed
Depends: libxcb-render-util0 (>= 0.2.1+git1) but it is not installable
Depends: libxcb1 (>= 1.1.92) but 1.1-1ubuntu1 is to be installed
E: Broken packages"

Hunter K. said...

sorry it didn't work for you. It appears that apt is having trouble resolving some of those dependencies. Which distro are you using? Are you using Ubuntu Jaunty?

If you feel up to it, you could always try building from the source code. I have some instructions for that located in another post (just search for 'updated build handbrake' in the search field on the right), and I'm happy to provide assistance with the process if needed.

mymazdatribute said...

Thank you, Thank you, Thank you!
A great number of english speaking anime fans (thousands) are going to continue to be very happy weakly due to your repository. I had updated handbrake directly via the .deb but couldent get it running even after updating the dependency's but your repository took care of the problem. Thanks on behalf of the thousands of viewers.

Analytics Tracking Footer